Implementing EIGRP using Cisco Packet Tracer

Home /

Table of Contents

Setting up EIGRP on a router is fairly simple. You enter the config mode, then enter the router EIGRP configuration. When you add some networks in here, the router turns on EIGRP. You must add the neighbor routers with whom this router will exchange EIGRP route information. When you exit command mode, remember to save your changes with the write memory command.

Router#config t
Router(config)#router eigrp ASN
Router(config-router)#network network SUBNET [WILCARD_MASK]
Router(config-router)#neighbor ip_address
Router(config-router)#exit
Router(config)#exit

The explanation of these commands, as well as detailed instructions on how to configure EIGRP using Cisco Packet Tracer, are provided below.

Establishment Of The EIGRP Neighborhood

EIGRP routers must first become neighbors before exchanging routing information. To dynamically discover neighbors on directly attached networks, EIGRP routers send hello packets to the multicast address 224.0.0.10.

To become neighbors, routers in a network must:

They must be configured with  the same ASN (Autonomous System Number). An autonomous system number is a group of EIGRP-enabled routers that should become EIGRP neighbors and exchange routes. Any number between 1 and 65,535 can be used.

Router(config)#router eigrp ASN

This command configures the router to use EIGRP. Routers must be configured with the same AS number in order to become EIGRP neighbors. Any number between 1 and 65,535 can be used.

The routers must also use the same parameters to compute the metric. These parameters are called K values (components of metric). The K values are bandwidth, delay, reliability, and load.

By default, the only parameters used to calculate the EIGRP metric are bandwidth and delay. The other two parameters are disabled by default, so the network administrator must enable them on the router to use them.

Each EIGRP router stores routing information in three tables.

The neighborhood table stores information about EIGRP neighbors. Remember that routers must first become neighbors before exchanging routing information. A neighborhood table is thus used to keep neighborhood information such as the IP address of the neighbor, the local interface on which hellos were received, the hold-down timer, and other neighbor information.

Topology tables are used to store routing data obtained from neighbor routing tables. Every EIGRP route within the autonomous system is stored in this location. The topology table also holds the metrics for each of the listed EIGRP routes, the feasible successor and the successor routes.

Routing table stores only the best routes to reach a remote network.
Router(config-router)#network network SUBNET [WILCARD_MASK]

This command advertises a network directly connected to the router to other routers.

Look at the following diagram. It is the same one we used to set up RIP. We will implement EIGRP now.

Implement EIGRP

The network, router, and end device IP addresses are listed below. This is required to logically connect the networks.

Router Configuration

Router0

InterfaceIP AddressSubnet Mask
GigabitEthernet0/0/0192.168.1.1255.255.255.0
Serial0/1/010.0.0.1255.0.0.0
Serial0/1/113.0.0.1255.0.0.0

CLI COMMAND:

Router>enable
Router#configure terminal
Router(config)#interface GigabitEthernet0/0/0
Router(config-if)#ip address 192.168.1.1 255.255.255.0
Router(config-if)#no shutdown
Router(config-if)#exit
Router(config)#interface Serial0/1/0
Router(config-if)#ip address 10.0.0.1 255.0.0.0
Router(config-if)#no shutdown
Router(config-if)#exit
Router(config)#interface Serial0/1/1
Router(config-if)#ip address 13.0.0.1 255.0.0.0
Router(config-if)#no shutdown
Router(config-if)#exit

Router1

InterfaceIP AddressSubnet Mask
GigabitEthernet0/0/0192.168.2.1255.255.255.0
Serial0/1/010.0.0.2255.0.0.0
Serial0/1/111.0.0.1255.0.0.0

CLI COMMAND:

Router>enable
Router#configure terminal
Router(config)#interface GigabitEthernet0/0/0
Router(config-if)#ip address 192.168.2.1 255.255.255.0
Router(config-if)#no shutdown
Router(config-if)#exit
Router(config)#interface Serial0/1/0
Router(config-if)#ip address 10.0.0.2 255.0.0.0
Router(config-if)#no shutdown
Router(config-if)#exit
Router(config)#interface Serial0/1/1
Router(config-if)#ip address 11.0.0.1 255.0.0.0
Router(config-if)#no shutdown
Router(config-if)#exit

Router2

InterfaceIP AddressSubnet Mask
GigabitEthernet0/0/0192.168.3.1255.255.255.0
Serial0/1/011.0.0.2255.0.0.0
Serial0/1/112.0.0.1255.0.0.0

CLI COMMAND:


Router>enable
Router#configure terminal
Router(config)#interface GigabitEthernet0/0/0
Router(config-if)#ip address 192.168.3.1 255.255.255.0
Router(config-if)#no shutdown
Router(config-if)#exit
Router(config)#interface Serial0/1/0
Router(config-if)#ip address 11.0.0.2 255.0.0.0
Router(config-if)#no shutdown
Router(config-if)#exit
Router(config)#interface Serial0/1/1
Router(config-if)#ip address 12.0.0.1 255.0.0.0
Router(config-if)#no shutdown
Router(config-if)#exit

Router3

InterfaceIP AddressSubnet Mask
GigabitEthernet0/0/0192.168.4.1255.255.255.0
Serial0/1/012.0.0.2255.0.0.0
Serial0/1/113.0.0.2255.0.0.0

CLI COMMAND:

Router>enable
Router#configure terminal
Router(config)#interface GigabitEthernet0/0/0
Router(config-if)#ip address 192.168.4.1 255.255.255.0
Router(config-if)#no shutdown
Router(config-if)#exit
Router(config)#interface Serial0/1/0
Router(config-if)#ip address 12.0.0.2 255.0.0.0
Router(config-if)#no shutdown
Router(config-if)#exit
Router(config)#interface Serial0/1/1
Router(config-if)#ip address 13.0.0.2 255.0.0.0
Router(config-if)#no shutdown
Router(config-if)#exit

The Shared network space between Router0 and Router1:
Network Address: 10.0.0.0/8
Subnet Mask: 255.255.255.0
Network type: Type A

The Shared network space between Router1 and Router2:
Network Address: 11.0.0.0/8
Subnet Mask: 255.255.255.0
Network type: Type A

The Shared network space between Router2 and Router3:
Network Address: 12.0.0.0/8
Subnet Mask: 255.255.255.0
Network type: Type A

The Shared network space between Router0 and Router3:
Network Address: 13.0.0.0/8
Subnet Mask: 255.255.255.0
Network type: Type A

Network 1
Network Address:192.168.1.0/24
Subnet Mask: 255.255.255.0
DeviceIP AddressSubnet MaskDefault Gateway
PC0192.168.1.101255.255.255.0192.168.1.1
Server0192.168.1.102255.255.255.0192.168.1.1
PC1192.168.1.103255.255.255.0192.168.1.1

Network 2
Network Address:192.168.2.0/24
Subnet Mask: 255.255.255.0
DeviceIP AddressSubnet MaskDefault Gateway
PC2192.168.2.101255.255.255.0192.168.2.1
PC3192.168.2.102255.255.255.0192.168.2.1

Network 3
Network Address:192.168.3.0/24
Subnet Mask: 255.255.255.0
DeviceIP AddressSubnet MaskDefault Gateway
PC4192.168.3.101255.255.255.0192.168.3.1
PC5192.168.3.102255.255.255.0192.168.3.1
Network 4
Network Address:192.168.4.0/24
Subnet Mask: 255.255.255.0
DeviceIP AddressSubnet MaskDefault Gateway
PC6192.168.4.101255.255.255.0192.168.4.1
PC7192.168.4.102255.255.255.0192.168.4.1

Setting Up EIGRP On The Routers

Remember to use the same ASN number on all the neighboring routers. When the routers are configured, they become EIGRP neighbors.

Router0
Router(config-if)#router eigrp 1
Router(config-router)#network 192.168.1.0
Router(config-router)#network 10.0.0.0
Router(config-router)#network 13.0.0.0
Router(config-router)#exit
Router(config)#exit
Router#write mem

Router1
Router(config-if)#router eigrp 1
Router(config-router)#network 192.168.2.0
Router(config-router)#network 10.0.0.0
Router(config-router)#network 13.0.0.0
Router(config-router)#exit
Router(config)#exit
Router#write mem

Router2
Router(config-if)#router eigrp 1
Router(config-router)#network 192.168.3.0
Router(config-router)#network 11.0.0.0
Router(config-router)#network 12.0.0.0
Router(config-router)#exit
Router(config)#exit
Router#write mem

Router3
Router(config-if)#router eigrp 1
Router(config-router)#network 192.168.4.0
Router(config-router)#network 12.0.0.0
Router(config-router)#network 13.0.0.0
Router(config-router)#exit
Router(config)#exit
Router#write mem

As you can see, we’re simply enabling EIGRP on the routers and then advertising networks that are directly connected to each router. Simple!

Verify The EIGRP Configuration

Let’s verify the routers’ EIGRP neighborhood relationship.

Let’s do it on Router0.

Router#show ip eigrp neighbors

Then observe the neighborhood:

IP-EIGRP neighbors for process 1
H   Address         Interface      Hold Uptime    SRTT   RTO   Q   Seq
                                   (sec)          (ms)        Cnt  Num
0   10.0.0.2        Se0/1/0        12   00:10:12  40     1000  0   9
1   13.0.0.2        Se0/1/1        12   00:00:25  40     1000  0   16

Router0 has two neighbors with IP addresses of 10.0.0.2 and 13.0.0.2, as shown in the diagram above.

Let’s do it on Router1.

Router#show ip eigrp neighbors

Then observe the neighborhood:


IP-EIGRP neighbors for process 1
H   Address         Interface      Hold Uptime    SRTT   RTO   Q   Seq
                                   (sec)          (ms)        Cnt  Num
0   10.0.0.1        Se0/1/0        12   00:10:33  40     1000  0   7
1   11.0.0.2        Se0/1/1        14   00:03:02  40     1000  0   9

Router1 has two neighbors with IP addresses of 10.0.0.1 and 11.0.0.2, as shown in the diagram above.

Let’s do it on Router2.

Router#show ip eigrp neighbors

Then observe the neighborhood

IP-EIGRP neighbors for process 1
H   Address         Interface      Hold Uptime    SRTT   RTO   Q   Seq
                                   (sec)          (ms)        Cnt  Num
0   11.0.0.1        Se0/1/0        13   00:03:17  40     1000  0   10
1   12.0.0.2        Se0/1/1        14   00:01:19  40     1000  0   15

Router2 has two neighbors with IP addresses of 11.0.0.1 and 12.0.0.2, as shown in the diagram above.

Let’s do it on Router3.

Router#show ip eigrp neighbors

Then observe the neighborhood:

IP-EIGRP neighbors for process 1
H   Address         Interface      Hold Uptime    SRTT   RTO   Q   Seq
                                   (sec)          (ms)        Cnt  Num
0   12.0.0.1        Se0/1/0        11   00:01:35  40     1000  0   10
1   13.0.0.1        Se0/1/1        11   00:01:17  40     1000  0   8

Router3 has two neighbors with IP addresses of 12.0.0.1 and 13.0.0.1, as shown in the diagram above.
Second, we’ll look at the route table that’s been saved in the routers. The show ip route eigrp command can be used.

Router0
Router#show ip route eigrp
10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
D 11.0.0.0/8 [90/2681856] via 10.0.0.2, 00:54:04, Serial0/1/0
D 12.0.0.0/8 [90/2681856] via 13.0.0.2, 00:51:48, Serial0/1/1
192.168.1.0/24 is variably subnetted, 2 subnets, 2 masks
D 192.168.2.0/24 [90/2172416] via 10.0.0.2, 00:06:24, Serial0/1/0
D 192.168.3.0/24 [90/2684416] via 13.0.0.2, 00:04:59, Serial0/1/1
[90/2684416] via 10.0.0.2, 00:04:59, Serial0/1/0
D 192.168.4.0/24 [90/2172416] via 13.0.0.2, 00:03:25, Serial0/1/1

Router1
Router#show ip route eigrp
11.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
D 12.0.0.0/8 [90/2681856] via 11.0.0.2, 00:53:27, Serial0/1/1
D 13.0.0.0/8 [90/2681856] via 10.0.0.1, 01:00:58, Serial0/1/0
D 192.168.1.0/24 [90/2172416] via 10.0.0.1, 00:18:38, Serial0/1/0
192.168.2.0/24 is variably subnetted, 2 subnets, 2 masks
D 192.168.3.0/24 [90/2172416] via 11.0.0.2, 00:04:22, Serial0/1/1
D 192.168.4.0/24 [90/2684416] via 10.0.0.1, 00:02:48, Serial0/1/0
[90/2684416] via 11.0.0.2, 00:02:48, Serial0/1/1

Router2
Router#show ip route eigrp
D 10.0.0.0/8 [90/2681856] via 11.0.0.1, 00:52:49, Serial0/1/0
12.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
D 13.0.0.0/8 [90/2681856] via 12.0.0.2, 00:50:33, Serial0/1/1
D 192.168.1.0/24 [90/2684416] via 11.0.0.1, 00:18:00, Serial0/1/0
[90/2684416] via 12.0.0.2, 00:18:00, Serial0/1/1
D 192.168.2.0/24 [90/2172416] via 11.0.0.1, 00:05:09, Serial0/1/0
192.168.3.0/24 is variably subnetted, 2 subnets, 2 masks
D 192.168.4.0/24 [90/2172416] via 12.0.0.2, 00:02:10, Serial0/1/1

Router3
Router#show ip route eigrp
D 10.0.0.0/8 [90/2681856] via 13.0.0.1, 00:49:51, Serial0/1/1
D 11.0.0.0/8 [90/2681856] via 12.0.0.1, 00:50:08, Serial0/1/0
13.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
D 192.168.1.0/24 [90/2172416] via 13.0.0.1, 00:17:18, Serial0/1/1
D 192.168.2.0/24 [90/2684416] via 12.0.0.1, 00:04:27, Serial0/1/0
[90/2684416] via 13.0.0.1, 00:04:27, Serial0/1/1
D 192.168.3.0/24 [90/2172416] via 12.0.0.1, 00:03:02, Serial0/1/0

Lastly, let us ping PC2 from PC0. Ping should be successful.

C:\>ping 192.168.2.101
Pinging 192.168.2.101 with 32 bytes of data:
Reply from 192.168.2.101: bytes=32 time=1ms TTL=126
Reply from 192.168.2.101: bytes=32 time=1ms TTL=126
Reply from 192.168.2.101: bytes=32 time=1ms TTL=126
Reply from 192.168.2.101: bytes=32 time=1ms TTL=126
Ping statistics for 192.168.2.101:
    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
    Minimum = 1ms, Maximum = 1ms, Average = 1ms

Q: How does a router know when a route goes down with EIGRP?

When a router detects that one of its interfaces is down, such as due to a broken cable or a router dies, it sends out an EIGRP update indicating that route is down. As a direct consequence, all routers receive the message and adjust their route tables.

Q: So, what should I do if not all of my routers are Ciscos?

If you don’t want to use RIP (and who can blame you ), OSPF is an option. It is widely supported, including on Cisco hardware.

Q: Is OSPF much different than EIGRP?

Both yes and no. It performs similarly to EIGRP but is conceptually very different. Its setup can also be a little more complicated.

Q: So why doesn’t everyone use EIGRP?

Because it is Cisco’s proprietary routing protocol, and no one else has licensed it that we are aware of.

Q: Does someone own OSPF?

OSPF, on the other hand, is an open standard. Any router manufacturer can use it on their products.

Because of your efforts, all of Hogwarts’ networks can now communicate with one another via their individual network devices. Congratulations!

Share The Tutorial With Your Friends
Twiter
Facebook
LinkedIn
Email
WhatsApp
Skype
Reddit

Check Our Ebook for This Online Course

Advanced topics are covered in this ebook with many practical examples.

Other Recommended Article